Lumin Community is down

Incident Report for Lumin

Resolved

This incident has been resolved.
Posted Apr 13, 2021 - 08:57 UTC

Investigating

We are currently investigating this issue.
Posted Apr 13, 2021 - 08:56 UTC
This incident affected: Lumin Community.